주요글: 도커 시작하기

Eclipse Luna for JavaEE Developver 버전을 다운로드 받으면 메이븐 연동을 위한 m2e 플러그인이 기본으로 설치되어 있다.


이클립스는 Subversion 연동 플러그인이 기본 포함되어 있지 않기 때문에, 이클립스 마켓플레이스 Help -> Eclipse Marketplace 메뉴에서 Subclipse 플러그인을 찾아서 설치했다. 글 쓰는 시점 기준으로 이 Subclipse 플러그인 버전은 1.10.5다.


Subclipse 플러그인을 설치하고, 이클립스를 재시작한 뒤에 Subclipse와 메이븐 연동을 위해 Window -> Preferences -> Maven ->Discovery -> [Open Catalog]를 실행해서 Subclipse 연동을 위한 m2e-subclipse 를 선택하고 [Finish] 버튼을 클릭했다. 그런데, 잠시 후에 다음과 같은 오류가 발생한다.




Operation details

Cannot complete the install because of a conflicting dependency.

Software being installed: Maven SCM handler for Subclipse 0.13.0.201303011221 (org.sonatype.m2e.subclipse.feature.feature.group 0.13.0.201303011221)

Software currently installed: Subclipse (Required) 1.10.5 (org.tigris.subversion.subclipse.feature.group 1.10.5)

Only one of the following can be installed at once: 

SVN Team Provider Core 1.8.22 (org.tigris.subversion.subclipse.core 1.8.22)

SVN Team Provider Core 1.10.5 (org.tigris.subversion.subclipse.core 1.10.5)

Cannot satisfy dependency:

From: Maven SCM Handler for Subclipse 0.13.0.201303011221 (org.sonatype.m2e.subclipse 0.13.0.201303011221)

To: bundle org.tigris.subversion.subclipse.core [1.6.0,1.9.0)

Cannot satisfy dependency:

From: Maven SCM handler for Subclipse 0.13.0.201303011221 (org.sonatype.m2e.subclipse.feature.feature.group 0.13.0.201303011221)

To: org.sonatype.m2e.subclipse [0.13.0.201303011221]

Cannot satisfy dependency:

From: Subclipse (Required) 1.10.5 (org.tigris.subversion.subclipse.feature.group 1.10.5)

To: org.tigris.subversion.subclipse.core [1.10.5]


이런 오류가 발생하는 이유는 m2e의 Subclipse Connector가 필요로 하는 Subclipse 버전과 실제 설치된 Subclipse 버전이 맞지 않기 때문이다.


이를 해결하려면 Marketplace에 설치한 Subclipse 1.10 버전을 제거하고, 1.8 버전을 설치하면 된다. Help -> Install New Software 를 이용해서 1.8 버전 설치를 진행한다. 업데이트 URL(work with...)은 다음 주소를 입력하면 된다.

  • http://subclipse.tigris.org/update_1.8.x

1.8 버전 Subclipse를 설치한 뒤에 다시 m2e Subclipse Connector를 설치하면 된다. 끝!



+ Recent posts